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Introduction
The following guide is intended to briefly introduce you to the
major elements of SDI Editor. This is not a reference manual
or a comprehensive list of Editor features.  This document
will introduce key features and provide the necessary information
to use those features.

During installation, graphic file types such as CGM, PDF, TIFF 
can be associated to Editor.  If this has been done, simply
double click on a CGM file using Windows Explorer to launch
Editor and open the CGM file.

As the name implies the opened file can be edited.  This means
that in addtion to adding content to the file, any object contained
in the file can be modified or deleted.  The objects in the file can
be manipulated using the commands on the floating tool bar.

Rulers (Options >) are located to the left and top of the drawing 
area to provide a reference.  Grid points can be turned on to 
assist placement of content.  View control is provided to zoom, 
and facilitate viewing.

These and other features will be discussed in the pages that
follow.

When the drawing is complete it can be saved, exported in one
of many formats or printed.  The file can be re-opened and editing
may continue, or content removed from the drawing.  



Getting Started

From the File menu, click NEW

The dialog on the left appears.  Select
one of the pre-defined sizes, or key-in
a custom page size in the field named
Image Size Selected or Entered.
Seperate the width from the height with
a blank space or lower case x character,

SAVE

When you are done editing, click SAVE.  The first file to save is the 
edit file which is a template of the work performed so far. When the
work is complete it may be saved as a CGM, exported as another 

AUTOSAVE

During the edit session automatic backups are made of the file, on
a given interval.  The interval is controled by the auto backup time 
located in the Options Menu.  The contents of the autobackup can
be retrieved by doing a recover last from the File menu.

OPEN
You may double click on a file, drag and
drop it on the drawing area or you may
select the OPEN option from the File menu
to open an existing file 

NEW
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and click OK.

file type or printed directly from the screen. Saving the .edit  
templates is optional but, recommended, as they are very useful 
and generally quite small as they contain links to inserted files 
rather than their contents. These edit templates can be re-opened
at any time to continue work in progress or to use as a base to
to quickly update earlier work with newer versions of inserted files.



The Floating Tool Bar
The floating toolbar appears whenever a file is opened or created.

Select Object

Create/Modify Hot Spot

Place Symbol

Rotate Object

Delete Object

Move Object to Front

Move Object to Back

Move Object One Level Up

Move Object One Level Down

Place Bezier Line

Select Group

Place Text

Place Boxed Text

Place Leader Line

Place Line

Place Polyline

Place Arc

Place Sweep Arrow

Place Polygon

Place Ellipse

Place Rectangle

Insert Graphic

Capture Rectangle

A tool tip appears when you hover the cursor over a command on
the toolbar.

Context sensitive attribute menus appear under the main menu for
each command that is selected. These allow you to enter text color,
for instance, when placing text.

Additional pop-up menus may also appear on certain commands.

The floating toolbar is used to create and manipulate objects.

The floating toolbar may be oriented horizontally, or vertically as 
shown below. (Right Mouse on Tool Bar to change orientation.)
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View Control

The menu bar contains 8 view control icons shown below;

From left to right:

Zoom In:  clicking once causes the display to zoom in about the 
point selected by a 2:1 factor. Use the zoom factor, in the zoom

Zoom Out: clicking once causes the display to zoom out about 
the point selected by a factor of 2:1.

Fit Width: Causes the existing display to be fit across the width
of the editor window, a vertical scroll bar will appear if the display
in the vertical dimension is larger than the editor window height.

Fit Height: Causes the existing display to be fit along the height
of the editor window. A horizontal scroll bar will appear if the 
display in the horizontal dimension is larger then the editor 
window's width.

Best Fit: Causes the entire drawing to be best fit inside the 
dimensions of the editor window.

Magnify: Causes the area beneath the magnifier to be pixel
zoomed 4x, as if looking through a magnifying lense.

Overview:  Turns on the overview window. The overview 
window displays a small representation of the entire display 
This is a convenient way to orient a zoomed view within the entire
drawing.  The overview can also be used to pan, zoom or resize.

Pan:  In pan mode, holding down the cursor causes the display
to track with the movement of the mouse.

menu to change the zoom factor.

In order to zoom a portion of the canvas to full screen; first, ensure 
no objects are selected, then, create a rectangle - left mouse 'hold' 
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on upper left corner and drag to lower right corner, then release. 
Area within the created rectangle will zoom to full screen.



Grids and Rulers

Grids allow you to create the appearance of grid paper on
your drawing area.  The spacing of the grids is controlled
in both the horizontal and vertical direction by the size you
set in the grid settings dialog.

RULERS

The on/off switch for rulers is found under the Options
menu.  The ruler is a check item, either on or off.

Rulers are displayed along the top of the canvas, and 
along the left hand side of the canvas. They are displayed in
the current Cursor Units, which may be selected under Options.
As the cursor tracks across the canvas, markers move
along each of the horizontal and the vertical rulers to identify
the current cursor location. The exact X and Y coordinates are

GRIDS

Grids are located in the Layout menu.  The current grid 
settings are saved with the fle.
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displayed in the bottom left corner of the Window.



Inserting Files

Once a file is inserted, it can be selected like any other primitive 
element and the attribute menu will be displayed as shown:

The attribute menu contains the file size, scale, and various other
manipulation commands explained later.  To precisely place the 
file, change the origin (left, right, top, bottom) and type in the new X 
and Y values, then press Enter.  To change the scale key-in a scale 
value and press Enter.  The location and scale can be changed by
using the cursor to drag the file, or by selecting a corner to modify
the size.  Rotation and crop commands are also available for 
inserted files.

Select the folder icon on the floating tool bar, browse
to locate a file.  Click to place the first point of a 
rectangle, drag and release to set the second point.
The dialog shown below appears.

Click Fit
To fit the file between the two
points provided.  A best fit,
preserving the aspect ratio 
will be used.

Click Apply Scale
To align the file with the first
point and draw the file at the
scale provided in the "scale
multipliers" text field.

When Checked, the boundaries  
are automatically expanded to prevent clipping of the imported file.

Resize The Drawing Area
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This option appears only if 
the file will not completely
fit in the current drawing area.



Rotation

Use the Select tool to select any primitive in the drawing area.
Right click the mouse to display the primitive command list.

Select the Rotate command.  A 
blue circle will appear.  Hold the 
left cursor button down in the 
circle and move the cursor to 
rotate the element.

Inserted files can be rotated in 90 degree increments by selecting  
the file and then using the rotate icons on the attribute menu.

The entire canvas can be rotated by using the rotate icons on the main
menubar.

Rotate Objects

Rotate the Canvas

Rotate an Inserted File
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Watermarks & Highlighting

PROOF
Transparency is an attribute of all primitives.  When used in 
conjuction with text, transparency can be used to highlight 
particular areas, or place watermarks. 

Highlighting may be accomplished by drawing a light colored object 
(circle or rectangle) over an area of interest. The Color Blending
option may be used to allow the data to show through if desired. 
Text can be highlighted by simply clicking the right mouse button
over the A text icon to enable selection of a background color.

Opaque Colors Blended Colors

To create the watermark text string "PROOF".  The text string
proof was pushed to the back of the drawing, under all items 
that were previously drawn.  Four commands are available on 
the floating tool bar to move elements forward and back.  The
commands are: "Move Object to Front", "Move Object to Back",
"Move Object One Level Up" and "Move Object One Level Back"
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Highlighted text.
Highlighted text.

Note the difference between circles drawn transparently vs. opaque.

Highlighted text examples:

Font Background Color 

Seismic shows through if
color blending is selected.

Right click on to select



Multi-Page PDF Well Logs

PDF Well Logs are just another case of multi-picture files.

A PDF, like any other multi picture file, is opened in Editor the 
same as any other file. However, at the bottom of the page, a  
text field indicates that this is a Multi-Page file. Adjacent to this,
the current and total number of pages in the file are displayed.

By selecting the right and left arrows you can navigate through   
the pages.

Once a Multi-Page PDF well log is concatenated into a 
single continuous well log, it is possible to manipulate the
file as you would any other well log.  The file may now be 
printed directly using the APS print option in SDI Editor.
Also, it may be exported as a Tiff, a CGM or another file type
for applications that do not support multi-page PDF's.

The original PDF file is left unchanged.  You can chose to
save continuous well logs as a CGM file or to Export them
in another format before exiting.

Four options are available for Multi-Page files:  Merge pages
Vertically or Horizontally.  Overlay pages, or the default,
leave all pages seperate (Multi-Page).

Well logs are not the only example of multi-page files. The
behavior of multi-page files is the same regardless of the
source.  Most PDF documents are multi-page, and output
from a sequence of screen captures is another example.

Multi-page documents can be exported as PowerPoint
files, where each page is a seperate slide, or streamed
together as a movie with a definable frame rate.
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Cropping
To crop the entire canvas select the crop command under the Edit
menu.  The cursor changes to crop mode.  Select the first point of
a rectangle and drag to create a rectangle, releasing the cursor to
select the second point.  The canvas is immediately cropped and
the new file is fit to the full canvas size.

Export Viewport is a form of the crop command where only the area
in the Viewport is exported.  This is the same as performing the crop
then exporting entire file, but done in one move.

Inserted files may also be cropped.  The insert file crop tool appears
on the object attribute menu when a file is selected.

There is a rectangular crop and a scissor crop for inserted files.  The
rectangular crop functions in a similar way to the canvas crop.

The Scissor Crop tool removes portions of a file bounded by the cut
lines made by the scissors either horizontally, or vertically.

Select the horizontal scissors, and click on the
image.  Now select the horizontal scissors again
and click a second time to achieve the result 
shown.

The far left command indicates that you have 
selected the center section between the cutlines.

When the section of a file above or below a single cutline is selected, 
the far left command indicates which one. Clicking on the command 
removes the selected section.
The command on the right is used to split the file at the cutline.
The center command is used to remove all unused cutlines.  The
vertical scissors operate in a similar manner to make vertical cuts.
With a little practice, you can slice and dice a file into many pieces.
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This value can be edited to eliminate or 
change the height of the space.

Clicking on the command will remove that
section and leave a gap of 1.37 inches.



Layer Management

The layer manager is found under the layout section of the 
menu bar.  The layer manager controls the creation and
configuration of the individual layers in the graphic display.
Layers are prioritized by the order they appear, a layer can
be moved up and down in the list to force all the elements 
on those layers to be above or below the elements on other

 

 

 

 

 

 

To create a layer, first a base layer must be created so 
that all existing primitives can be assigned to the base
layer.  Once this is done, new layers can be created.  A
primitive can be created on the active layer, or it can be
moved or copied to a new layer.

The eye icon    controls the visibility of the layer, it has 3 
values, on, off and gray.

The pen icon    controls wether the layer is writeable or write
locked.

The disk icon    controls wether the contents of the layer are
saved when the file is saved.  Layers can be saved even if
not visible. Only visible layers are printed.

To control the priority of a layer, simply select the layer and
drag it up or down to place it above or below another layer.

The highlighted layer is the active layer on to which all new
primitives are drawn.

layers.
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Using Windows Fonts
By default, Editor will display only a limited number of fonts when
you place text.  The reason for this has to do with the CGM 
standard.  In the Petroleum industry, or in the Aerospace industry
CGM is rigorously defined and contains only a limited number of
fonts.  This guarantees that different vendors will display the same
file in the same way. It is important to remember this, if you wish to 
create portable graphic files.

There are other times when the files you are creating will be used
with other Windows applications and access to the additional fonts 
will be beneficial, e.g. export of PDF's and PowerPoint slides.
To add additional fonts to Editor, select the Default Draw Options
from the Options menu.  Now select the Text tab from the pop up
dialog.

Select multiple fonts from the Available Fonts list, and click Add to
move them into the Selected Fonts list.  All fonts in the Selected
list will be available when you place text.  The fields on the left
side of the dialog can be used to set the default values for text
placement when you open a new file.  Settings will be saved from
then on.  To match an existing text, simply select the text with the
select tool on the tool bar, then select the text command.  All the
attributes from the selection will be used to place the text.
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Symbols

A set of pre-defined symbols are included with the Editor.  Select
the symbol command      on the Floating Tool Bar and the attribute

Click on the active symbol, to open the Symbol Selector popup.
Browse through the symbol pages, and click on a symbol to select it.
You may keep the symbol dialog open or closed while placing 
symbols.

To add additional symbols to the symbol list, or to create alternate
symbol libraries first copy the symbol library to a working folder on
your workstation.  (Note: Windows protects the files that are stored
in "Program Files" so you cannot edit the symbol file where it is
located.)  Open the file sdi_symbol_lib2.cgm. This is a multi page
CGM with each page exactly one inch square.  Move to the last page 
and select "After" in the Insert Page option in the Layout menu. 
Now, insert a bitmap icon or create a new symbol with the drawing
tools. Ensure it fills the drawing area. Save the file, and copy it back

the Editor session again, select Symbol     and scroll through the 
into the SDI Software bin directory under program files.  Now, open 

Symbol Selector to locate the new symbols you have created.

Though you may have multiple symbol libraries you can use only one
at a time in your open drawing.  To use additional libraries, you must
first close and save the file as a CGM. Then copy the new library into
place, and reopen the file.  This limitation will be corrected.
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menu will show the currrently selected symbol and its attributes.



Export Files
Just as you can save your current canvas as a CGM, you can
export your current canvas or a part of it as one of many different
graphic file formats.  Postscript, Adobe PDF, AutoCad DWG, DXF
TIFF and JPEG are amongst the formats you can select.  You can
even export movies or PowerPoint presentation files.

The Export menu lets you select the
entire canvas (file), a viewport or
rectangular area or export a multi-
page file as a movie.  Movie creation
will be covered under another topic.

The first thing to select is the export
format.  The clipboard can be used 
to take your data directly to another
windows application. JPEG, TIFF and 
PNG are image formats and have a
fixed resolution which you can select. 

Vector formats like PDF are scalable, so they will look good at any
size.  Each format will have slightly different options that are specific
to the particular file format.
PDF, CGM and PowerPoint are multi-page formats and will transfer
each page, one for one, into the other format.  More detail on
specific formats is available in the reference pages.
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Hot Spots

What are hot spots?

Hot spots are areas placed in your drawing that activate other
events.  These events can be the display of another file, or the
execution of a program, or the display of a web site.
Hot spots are usually invisible until your cursor moves over 
the spot, at this point a tool tip may appear to inform you that
clicking on this spot will activate a particular command.
Several hot spot examples are provided with Editor so that
you may become familiar with uses of hot spots.            

The dialog shown
on the left will be
displayed.

You can turn off hot spot behavior using the Options command
"hide hotspots"

A default ID will be
set by the Editor
program

Select the hot spot command from the floating tool bar.

Key-in the screen tip
and the name of the 
command.  Now use
the browse or key-in
the command to 
execute when this
object is selected.

The command buttons,
in red, can be used to

define the boundary of the object or button that will be the command.
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